Kamis, 22 Juli 2010

MANAJEMEN BANDWIDTH DENGAN MIKROTIK

1.Pendahuluan
Kehandalan ISP dalam melakukan manajemen bandwidth saat ini menjadi salah satu indikator sebuah ISP memberikan fleksibilitas layanan bagi pelanggan. Dan seperti gayung bersambut banyak pelanggan yang merasa nyaman dengan tipe ISP seperti ini sehingga pelanggan sangat setia untuk tetap menggunakan akses internet dari ISP tersebut.

Dan tentunya untuk penggunaan bandwidth limiting. Hasilnya, efisiensi jaringan akan meningkat seiring dengan pengurangan keperluan bandwidth secara keseluruhan. Ini juga dapat digunakan untuk memberikan akses yang terbatas untuk pengguna komputer di jaringan, sehingga pengguna-pengguna yang haus bandwidth (yang suka streaming atau download) bakalan dibatasi dengan software ini, sehingga pengguna lain tidak akan merasa kecepatan browsing atau download terganggu dengan si penyedot bandwidth tersebut.

Mengenai pembagian sharing bandwith yang adil dan yang pasti bisa membatasi semua jenis trafik baik IDM maupun P2P sehingga gak perlu takut kalau jatah bandwidth terambil oleh user lain, saya coba untuk mensharing berikut langkah-langkah yang mesti dilakukan pada winbox mikrotik.


2. Bagi Bandwidth untuk pelanggan yang berbeda
Setiap ISP yang berkembang pasti memiliki pelanggan yang berbeda-beda tipe dan biasanya dapat dikategorikan dengan berapa besar uang yang harus dibayar ke ISP tiap bulannya. Dalam contoh berikut ini kita kategorikan pelanggan corporate atau perusahaan dan pelanggan biasa atau rumahan.

Konfigurasi Jaringan :
Public --- (172.16.30.1/24) MT (10.10.10.1/24)--- Local

Skenarionya seperti ini :
Client 10.10.10.20 --- Bandwidth 128kbps 1:1 (corporate)
(128k up / 128k down)

Client 10.10.10.21, 22, 23 --- Bandwidth 128kbps 1:3 (personal)
(40k up / 128k down)


Maksud nya begini,kita ada bandwidth 256kbps,dari 256 itu ada 4 PC yang akan kita bagi dengan ketentuan di antara 4 itu ada 1 server yang di buat,dan server di dapat bandwidth lebih,jadi saya di sini menggunakan IP 10.10.10.20 sebagai server,dan dia mendapatkan bandwidth 128kbps,dan 128kbps lagi di bagi 3 user yaitu dengan IP 10.10.10.21,22,23.

Berikut cara pembagian bandwidth nya, pertama-tama kita lakukan pembuatan pada winbox di mangle :

Untuk trafik upload corporate

/ip firewall mangle add chain=prerouting src-address=10.10.10.20 in-interface=Local action=mark-packet new-packet-mark=corporate-up passthrough=no

Maksudnya disini pada ip firewall mange add chain dengan pilihan prerouting,dan source addres nya 10.10.10.20,pada in-interface kita set local,dan untuk action nya pilih mark-packet dan untuk new-packet-mark pilih corporate-up dan passthrough jangan di centang yang berarti no,ini merupakan cara manual nya,ada cara yang lebih mudah yaitu copy kan saja perintah di atas ke terminal nya,tapi untuk pemula lebih baik coba dengan cara manual tersebut.

Untuk trafik download corporate
/ip firewall mangle add chain=forward src-address=10.10.10.20 action=mark-connection new-connection-mark=corporate-conn passthrough=yes

/ip firewall mangle add chain=forward connection-mark=corporate-conn in-interface=Public action=mark-packet new-packet-mark=corporate-down passthrough=no

Untuk trafik upload personal
/ip firewall mangle add chain=prerouting src-address=10.10.10.21 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=10.10.10.22 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=10.10.10.23 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no


Untuk trafik download personal
/ip firewall mangle add chain=forward src-address=10.10.10.21 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=10.10.10.22 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=10.10.10.23 action=mark-connection new-connection-mark=personal-conn passthrough=yes


/ip firewall mangle add chain=forward connection-mark=personal-conn in-interface=Public action=mark-packet new-packet-mark=personal-down passthrough=no

Harap diperhatikan untuk mark-packet maka passthrough=no sedangkan untuk mark-connection passthrough=yes

maka proses di mangle sudah selesai,dan tampilan nya seperti gambar berikut:











Kemudian setelah selesai di mangle, kita lanjut ke pembuatan queue tree :
/queue tree add name=down parent=Local queue=default
/queue tree add name=up parent=global-in queue=default

seperti di tunjukkan pada gambar berikut:





















Maksudnya adalah kita membuat folder up dan down pada quee tree.

untuk download kita menggunakan in-interface kita dalam hal ini Local, sedangkan untuk upload kita menggunakan global-in

selanjutnya kita tambahkan type baru di queue :
yang harus kita tambahkan melihat skenario diatas adalah PCQ untuk paket corporate 128kbps (1:1) dan paket personal 128kbps (1:4).


Untuk paket corporate kita langsung menetapkan angka 256kbps, sedangkan untuk personal kita tidak dapat menetapkan angka disini karena bandiwdth yang akan diterima oleh paket personal tergantung seberapa banyak user yang online, jadi jika hanya 1 orang online akan mendapatkan bw penuh 128kbps, kalau 2 orang online maka masing-masing akan mendapatkan 64 kbps dan seterusnya.


/queue type add name=128-down kind=pcq pcq-rate=128k pcq-classifier=dst-address pcq-total-limit=2000
/queue type add name=128-up kind=pcq rate=128k pcq-classifier=src-address pcq-total-limit=2000




















/queue type add name=auto-down kind=pcq pcq-rate=0 pcq-classifier=dst-address pcq-total-limit=2000
/queue type add name=auto-up kind=pcq rate=0 pcq-classifier=src-address pcq-total-limit=2000

Maka akan muncul seperti gambar berikut:




















kita menggunakan 0 pada paket personal karena Mikrotik akan menghitung berapa besar bandwidth yang tersedia pada saat client melakukan koneksi.

Nah setelah itu kita kembali ke queue tree dan menambahkan :
Paket corporate
/queue tree add name=corp-down packet-mark=corporate-down parent=down queue=128-down
/queue tree add name=corp-up parent=up packet-mark=corporate-up queue=128-up











Maksudnya adalah kita membuat folder corp-down di parent down yaitu di folder down yang teleh kita buat tadi,jadi di dalam down ada corp-down.












Paket personal
/queue tree add name=per-down packet-mark=personal-down parent=down queue=auto-down max-limit=128k











/queue tree add name=per-up parent=up packet-mark=personal-up queue=auto-up max-limit=40k












Setelah siap semuanya maka akan tampil seperti berikut:











Maka manajement bandwidth telah selesai,pada gambar diatas terlihat bahwa tanda per-down nya berwarna merah,maksud nya ada user client nya yang sedang mendownload dan melebihi kapasitas bandwidth yang telah di tentukan,maka akan di batasi oleh manajemen bandwidth kita tadi,sedangkan untuk corp-down nya yang merah,itu berarti servernya sedang mendownload dan melebihi kapasitas bandwidth yang di tentukan.

Sekian dan selamat mencoba,,,,!!!


REFERENSI




Tidak ada komentar:

Poskan Komentar